Why Isn't My Active Leveling Working?

There are a number of different error messages you might see on your Ultimaker 3 series or Ultimaker S-line printer regarding the active leveling process. There are a few different errors you may see, but the most common is "Difference between detected height of both PrintCores exceeds realistic values."

Your printer always expects to find a height difference of 1.5mm between your left hand (Slot 1) Print Core and your right hand (Slot 2) Print Core. The left hand Print Core is stationary and will always be at the same height. The right hand Print Core moves up and down 3mm depending on the position of the Lifting Switch on the right side of the printhead. This allows it to always be either 1.5mm below the left hand Print Core, or 1.5mm above the left hand Print Core. When the Print Core in Slot 2 is actively printing, it will be in the lower position, so that the Slot 1 Print Core does not drag over the printed parts. When the Print Core in Slot 1 is actively printing, the Print Core in Slot 2 will retract out of the way.

If there is debris on your bed, or filament hanging off the end of your nozzle, it will change the perceived height of the bed. It's not uncommon for filament to appear on the tip of the nozzle during the active leveling process, because the Print Cores do heat partially during the active leveling. If this happens, wipe the Print Core off with a paper towel, and try the active leveling process again.

One of the other most common reasons to receive this message on an Ultimaker 3 or Ultimaker 3 Extended, is usually that the build plate is starting from too high of a position at the start of the active leveling process. When this happens, you may also see the nozzle of your Print Core get pushed inside the print head. 

Compare these photos:

In this photo, the bed is too high, because the spring tension is too loose. You can see quite a larger gap between the bottom of the heated bed plate, and the tallest part of the metal lip on the base plate. You can also see that the right hand Print Core has been pushed up inside the nozzle to the point where it is now at the same height as the left hand Print Core. The 2 Cores should never bee at the same height.

Screen_Shot_2017-11-21_at_12.20.56_PM__1_.png

In this photo, you can see that there is only a very small gap between the bottom of the heated plate, and the tallest part of the base plate's lip. This is because the bed springs are correctly tightened. You can also see that the Slot 2 Print Core is hanging down lower than the Slot 1 Print Core; because the bed is at the right height, the Core has not been forced inside the print head.

IMG_0907.JPG

This video will walk you through tightening the thumbscrews and spring tension to resolve this error.

Another way to check the height of your bed is to print this 14mm spacer. In a pinch, you could disable active leveling, do a manual bed leveling, and print this, and then go ahead and turn your manual leveling back on after you've checked the height. 

Bed_Leveling_Tool.jpg

If you're still seeing active leveling issues after the bed height is set correctly, there are a couple of other things to check--your capacitive sensor cables, and your front fan.

To check the capacitive cable: this is the white and red cable that plugs into the metal bracket at the underside of your printhead. If it's not seated fully, the active leveling will fail. It's not uncommon for damage to occur to this cable if you find filament in the printhead. If you're not sure, please send a photo over.

 

To check the fan cable: this is the white and black cable for your front fan; if it's become pinched at some point during the clean up process it can create electrical interference that will prevent the active leveling from working correctly, even though the fan still runs. To check this, unplug the white and black cable from the connector at the back of the printhead and try leveling it again. If it works correctly unplugged the fan will need to be replaced.

Was this article helpful?
7 out of 8 found this helpful
Have more questions? Submit a request

Comments

3 comments
  • Hello, 3 questions:
    1) Why does the UMS3 go so low when active bed leveling begins? (almost 2cm below the nozzle tip)?
    2) Is there any tool for bed leveling for the S series?
    3) Why sometimes active bed leveling doesn't work until you change the printcores?

    0
    Comment actions Permalink
  • I have an UMS3 and I am interested in using this tool, although it looks like I might not have enough room to fit it in the side of my bed/bedplate I measured only about 6mm of space to fit this tool into between the spring and the metal that is curled up from the bottom blocking me from getting in. I see it works with UM3 but does anyone know this will work with the UMS3?

    0
    Comment actions Permalink
  • Hi, Ted and Gon, this tool unfortunatley does not fit with the S5 or S3 build plate. I can take a look and see if there's a tool we can make available for that. In general however, the bed height is less likely to be the cause of the active leveling error on your S5 or S3 compared to the UM3/UM3X, because there's much less extra space to account for on the S-line thumbscrews and spring set up. The S-line thumb screw is much longer than the UM3 one, so there's less variance that can be caused by the spring tension.

    Regarding the Print Cores: you can have active leveling failures caused by filament hanging off the Print Core, or if a Print Core has been disassembled for any reason (we do not recommend this), it could change the total height of the Print Core and disrupt the active leveling.

    1
    Comment actions Permalink

Please sign in to leave a comment.